Back
Maintenance

Scheduled maintenance of Gaming service

Completed 3 May at 03:30pm UTC.

Gaming service
Completed

Maintenance completed

Posted 3 May at 03:30pm UTC.
Started

Please be aware that gaming service will be unavailable at 28.04.2022 to 03.05.2022 as the IT team will be performing scheduled maintenance at this time.

During this time, you will be unable to open casino games.

This maintenance is necessary for new technical updates. We apologize for any inconvenience.

Posted 28 Apr at 03:00pm UTC.