Back
Maintenance
Maintenance
Planned Maintenance
Completed 9 Jul at 03:00am UTC.
Backend (API)
Admin dashboard
Sports betting
Gaming service
Payment service
betmaster.com
betmaster.eu
betmaster.co.uk
betmaster.ie
betmaster.ee
casinoin.ie
casinoin.ee
bongo.io
System Emails
Marketing Emails
Completed
Maintenance completed
Posted
9 Jul at 03:00am UTC.
Started
Start Time: 7/9/2025 01:00 am UTC
End Time: 7/9/2025 03:00 am UTC
We would like to inform you that scheduled system maintenance will be carried out during the above-mentioned time frame.
As part of these planned works, systems will undergo an update. Users may experience short-term disruptions, including temporary error messages or reduced access to our services, lasting no longer than 30 minutes.
These activities are essential to ensure the continued stability and performance of our platform.
Posted
9 Jul at 01:00am UTC.