Back
Downtime
Downtime
Casino Game Service is not available
Started 27 May at 08:00pm UTC, resolved 27 May at 08:50pm UTC.
Gaming service
Resolved
The technical issues with the Casino service has been resolved. Everything is now functioning as expected.
Thank you for your patience!
Posted 27 May at 08:50pm UTC.
Created
We are currently experiencing technical issues with the Torrero service, casino games are not available now. Our specialists are working to resolve this as quickly as possible.
Thank you for your understanding!
Posted 27 May at 08:00pm UTC.