Back
Resolved

Technical issue regarding sport betting service

Started 25 Apr at 10:00am UTC.

Sports betting
Created

Please note that due technical problem sport bets cannot be accepted now. This issue is under investigation by our and provider specialists.

Posted 25 Apr at 10:00am UTC.