Back
Resolved

Marketing offers cannot be reached

Started 13 Oct at 03:40pm UTC.

Other incidents
Created

Currently due to the bug marketing offers are not available for users to participate in.

Posted 13 Oct at 03:40pm UTC.