Back
Downtime

Technical issue regarding sport betting service

Started 10 Sep at 11:59am UTC, resolved 10 Sep at 05:29pm UTC.

Sports betting
Resolved

The issue with sport betting was resolved.

Posted 10 Sep at 05:29pm UTC.
Updated

We have identified the root cause of the issue. It will be resolved in the nearest future. We apologize for inconvenience caused!

Posted 10 Sep at 02:54pm UTC.
Created

Technical issue regarding sport betting service. Customers cannot bet on sport events, bets are denied.

Posted 10 Sep at 11:59am UTC.