Back
Resolved

Technical issue regarding sport betting service

Started 14 Jul at 09:57pm UTC.

Sports betting
Created

We are aware of an issue causing not working sport betting service.
Unfortunately, it is unable to bet on sport events.
Our engineers are aware of it and we will keep you posted.

Posted 14 Jul at 09:57pm UTC.